ddi_dma_devalign - find DMA mapping alignment and minimum transfer size
#include <sys/conf.h> #include <sys/ddi.h> #include <sys/sunddi.h> int ddi_dma_devalign(ddi_dma_handle_t handle, uint_t *alignment, uint_t *minxfr);
Solaris DDI specific (Solaris DDI). This interface is obsolete.
The DMAhandle filled in by a successful call to ddi_dma_setup(9F).
A pointer to an unsigned integer to be filled in with the minimum required alignment for DMA. The alignment is guaranteed to be a power of two.
A pointer to an unsigned integer to be filled in with the minimum effective transfer size (see ddi_iomin(9F), ddi_dma_lim_sparc(9S) and ddi_dma_lim_x86(9S)). This also is guaranteed to be a power of two.
The ddi_dma_devalign() Function determines after a successful DMA mapping (see ddi_dma_setup(9F)) the minimum required data alignment and minimum DMA transfer size.
The ddi_dma_devalign() function returns:
The alignment and minxfr values have been filled.
The handle was illegal.
The ddi_dma_devalign() function can be called from user, interrupt, or kernel context.
See attributes(5) for descriptions of the following attributes: