Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_unbind_handle(9F)

Name

ddi_dma_unbind_handle - unbinds the address in a DMA handle

Synopsis

#include <sys/ddi.h> 
#include <sys/sunddi.h>

int ddi_dma_unbind_handle(ddi_dma_handle_t handle);

Parameters

handle

The DMA handle previously allocated by a call to ddi_dma_alloc_handle(9F).

Interface Level

Solaris DDI specific (Solaris DDI).

Description

ddi_dma_unbind_handle() frees all DMA resources associated with an existing DMA handle. When a DMA transfer completes, the driver should call ddi_dma_unbind_handle() to free system DMA resources established by a call to ddi_dma_buf_bind_handle(9F) or ddi_dma_addr_bind_handle(9F). ddi_dma_unbind_handle() does an implicit ddi_dma_sync(9F) making further synchronization steps unnecessary.

Return Values

DDI_SUCCESS

on success

DDI_FAILURE

on failure

Context

ddi_dma_unbind_handle() can be called from user, kernel, or interrupt context.

See Also

ddi_dma_addr_bind_handle(9F), ddi_dma_alloc_handle(9F), ddi_dma_buf_bind_handle(9F), ddi_dma_free_handle(9F), ddi_dma_sync(9F)

Writing Device Drivers for Oracle Solaris 11.3