Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

hook_alloc(9F)

Name

hook_alloc - allocate a hook_t data structure

Synopsis

#include <sys/hook.h>

hook_t *hook_alloc(const int version);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

version

must always be the symbol HOOK_VERSION.

Description

The hook_alloc() function allocates a hook_t structure, returning a pointer for the caller to use.

Return Values

Upon success, hook_alloc() returns a pointer to the allocated hook_t structure. On failure, hook_alloc() returns a NULL pointer.

Context

The hook_alloc() function may be called from user or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

hook_free(9F), hook_t(9S)