Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_get_parent(9F)

Name

ddi_get_parent - find the parent of a device information structure

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

dev_info_t *ddi_get_parent(dev_info_t *dip);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

Pointer to a device information structure.

Description

The ddi_get_parent() function returns a pointer to the device information structure which is the parent of the one pointed to by dip.

Return Values

The ddi_get_parent() function returns a pointer to a device information structure.

Context

The ddi_get_parent() function can be called from user, interrupt, or kernel context.

See Also

Writing Device Drivers for Oracle Solaris 11.3