Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

bioaligned(9F)

Name

bioaligned - check alignment of buffer data

Synopsis

#include<sys/ddi.h>
#include<sys/sunddi.h>

int bioaligned(struct buf *bp, size_t align, int flags);

Parameters

bp

Pointer to the buf(9S) structure describing the original I/O request.

align

Power of two alignment being checked.

flags

Determines the type of alignment being checked. Flag values supported are BIOALIGNED_BEGIN (which checks the beginning address alignment), and BIOALIGNED_END (which checks the ending address alignment).

Interface Level

Solaris DDI specific (Solaris DDI).

Description

The bioaligned() function checks the alignment of memory associated with a buffer. It returns 1 if the buffer is aligned and 0 if the buffer is unaligned.

Return Values

The bioaligned() function returns 1 if the buffer is aligned and 0 if the buffer is unaligned.

Context

The bioaligned() function can be called from any context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), biodone(9F), bp_mapin(9F), freerbuf(9F), getrbuf(9F), buf(9S)