Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

pci_plist_getvf(9F)

Name

pci_plist_getvf - get the name-value pair list for the VF device

Synopsis

#include <sys/sunddi.h>

int pci_plist_getvf(pci_param_t param, uint16_t vf_index,
     pci_plist_t *vfplist_p);

Parameters

param

A handle obtained from pci_param_get(9F) or pci_param_get_ioctl(9F).

vf_index

0 through #VFS -1

plist_p

A pointer to pci_param_plist_t where a non—null plist_p is returned on successful return

Description

The vfplist_p returned by pci_plist_getvf() is similar to nvlist_t and contains the name-value pairs for the VF (Virtual Function) device. The pci_plist_t supports the following data types:

uchar, int8_t, uint8_t, int16_t uint16_t, int32_t, uint32_t, int64_t, 
uint64_t, char *, pci_plist_t

Arrays of the above data types are supported.

Return Values

DDI_SUCCESS

On success.

Non-zero value

There is no name-value list for VF device.

Context

The pci_param_get() function can be called from kernel non-interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Uncommitted

See Also

attributes(5), pci_param_free(9F), pci_param_get(9F), pci_param_get_ioctl(9F), pci_plist_get(9F)