Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_driver_name(9F)

Name

ddi_driver_name - return normalized driver name

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

const char *ddi_driver_name(dev_info_t *devi);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

A pointer to the device's dev_info structure.

Description

ddi_driver_name() returns the normalized driver name. This name is typically derived from the device name property or the device compatible property. If this name is a driver alias, the corresponding driver name is returned.

Return Values

ddi_driver_name() returns the actual name of the driver bound to a device.

Context

ddi_driver_name() can be called from kernel, or interrupt context.

See Also

ddi_get_name(9F)

Writing Device Drivers for Oracle Solaris 11.3

Warnings

The name returned by ddi_driver_name() is read-only.