net_hook_unregister - disable a hook that was called in event processing
#include <sys/neti.h> int net_hook_unregister(net_handle_t net, char *hook_name, hook_t hook);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_register().
hook name to be unregistered
value returned from a successful call to net_hook_register(9F).
The net_hook_unregister() function disables the callback hooks that were registered with the net_hook_register() function.
If the net_hook_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered.
The net_hook_unregister() function may be called from user, kernel, or interrupt context.
See attributes(5) for descriptions of the following attributes: