Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

IOC_CONVERT_FROM(9F)

Name

IOC_CONVERT_FROM - determine if there is a need to translate M_IOCTL contents.

Synopsis

#include <sys/stream.h>

uint_t IOC_CONVERT_FROM(struct iocblk *iocp);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

iocp

A pointer to the M_IOCTL control structure.

Description

The IOC_CONVERT_FROM macro is used to see if the contents of the current M_IOCTL message had its origin in a different C Language Type Model.

Return Values

The IOC_CONVERT_FROM() function returns the following values:

IOC_ILP32

This is an LP64 kernel and the M_IOCTL originated in an ILP32 user process.

IOC_NONE

The M_IOCTL message uses the same C Language Type Model as this calling module or driver.

Context

The IOC_CONVERT_FROM() macro can be called from user, interrupt, or kernel context.

See Also

ddi_model_convert_from(9F)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide