Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_netidtozonid(9F)

Name

net_netidtozonid - map a netid_t structure identifier to a zoneid_t structure

Synopsis

#include <sys/neti.h>

zoneid_t net_netidtozonid(const netid_t net);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

valid netid_t structure that refers to an existing IP instance.

Description

The net_netidtozonid() function maps the given netid_t (used to represent an instance of IP) into the matching zoneid_t structure that is associated with it.

Return Values

The net_netidtozonid() function returns -1 if no mapping took place. Otherwise, it returns the zoneid_t structure currently associated with a netid_t structure. For shared stack zones, the zoneid_t structure for the global zone is returned.

Context

The net_netidtozonid() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_zoneidtonetid(9F), attributes(5)