Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

clrbuf(9F)

Name

clrbuf - erase the contents of a buffer

Synopsis

#include <sys/types.h>
#include <sys/buf.h>

void clrbuf(struct buf *bp);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

bp

Pointer to the buf(9S) structure.

Description

The clrbuf() function zeros a buffer and sets the b_resid member of the buf(9S) structure to 0. Zeros are placed in the buffer starting at bp→b_un.b_addr for a length of bp→b_bcount bytes. b_un.b_addr and b_bcount are members of the buf(9S) data structure.

Context

The clrbuf() function can be called from user, interrupt, or kernel context.

See Also

getrbuf(9F), buf(9S)

Writing Device Drivers for Oracle Solaris 11.3