Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_burstsizes(9F)

Name

ddi_dma_burstsizes - find out the allowed burst sizes for a DMA mapping

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_burstsizes(ddi_dma_handle_t handle);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

handle

A DMA handle that was filled in by a successful call to ddi_dma_setup(9F).

Description

ddi_dma_burstsizes() returns the allowed burst sizes for a DMA mapping. This value is derived from the dlim_burstsizes member of the ddi_dma_lim_sparc(9S) structure, but it shows the allowable burstsizes after imposing on it the limitations of other device layers in addition to device's own limitations.

Return Values

ddi_dma_burstsizes() returns a binary encoded value of the allowable DMA burst sizes. See ddi_dma_lim_sparc(9S) for a discussion of DMA burst sizes.

Context

This function can be called from user or interrupt context.

See Also

ddi_dma_devalign(9F), ddi_dma_setup(9F), ddi_dma_lim_sparc(9S), ddi_dma_req(9S)

Writing Device Drivers for Oracle Solaris 11.3