Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_segtocookie(9F)

Name

ddi_dma_segtocookie - convert a DMA segment to a DMA address cookie

Synopsis

#include <sys/ddi.h> 
#include <sys/sunddi.h>

int ddi_dma_segtocookie(ddi_dma_seg_t seg, off_t *offp, off_t *lenp,
     ddi_dma_cookie_t *cookiep);

Interface Level

This interface is obsolete. ddi_dma_nextcookie(9F) should be used instead.

Parameters

seg

A DMA segment.

offp

A pointer to an off_t. Upon a successful return, it is filled in with the offset. This segment is addressing within the object.

lenp

The byte length. This segment is addressing within the object.

cookiep

A pointer to a DMA cookie (see ddi_dma_cookie(9S)).

Description

The ddi_dma_segtocookie() function takes a DMA segment and fills in the cookie pointed to by cookiep with the appropriate address, length, and bus type to be used to program the DMA engine. ddi_dma_segtocookie() also fills in *offp and *lenp, which specify the range within the object.

Return Values

The ddi_dma_segtocookie() function returns:

DDI_SUCCESS

Successfully filled in all values.

DDI_FAILURE

Failed to successfully fill in all values.

Context

The ddi_dma_segtocookie() function can be called from user, interrupt, or kernel context.

Examples

Example 1 ddi_dma_segtocookie() example
for (win = NULL; (retw = ddi_dma_nextwin(handle, win, &nwin)) !=
    DDI_DMA_DONE; win = nwin) {
	if (retw != DDI_SUCCESS) {
		/* do error handling */
	} else {
		for (seg = NULL; (rets = ddi_dma_nextseg(nwin, seg, &nseg)) !=
		    DDI_DMA_DONE; seg = nseg) {
			if (rets != DDI_SUCCESS) {

				/* do error handling */ 
			} else {
				ddi_dma_segtocookie(nseg, &off, &len, &cookie);

				/* program DMA engine */
			}
		}
	}
}

Attributes

See attributes(5) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Stability Level
Obsolete

See Also

attributes(5), ddi_dma_nextcookie(9F). ddi_dma_nextseg(9F), ddi_dma_nextwin(9F), ddi_dma_sync(9F), ddi_dma_cookie(9S)

Writing Device Drivers for Oracle Solaris 11.3