Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

enableok(9F)

Name

enableok - reschedule a queue for service

Synopsis

#include <sys/stream.h>
#include <sys/ddi.h>

void enableok(queue_t *q);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

A pointer to the queue to be rescheduled.

Description

The enableok() function enables queue q to be rescheduled for service. It reverses the effect of a previous call to noenable(9F) on q by turning off the QNOENB flag in the queue.

Context

The enableok() function can be called from user, interrupt, or kernel context.

Examples

Example 1 Using emableok()

The qrestart() routine uses two STREAMS functions to restart a queue that has been disabled. The enableok() function turns off the QNOENB flag, allowing the qenable(9F) to schedule the queue for immediate processing.

1  void
2  qrestart(rdwr_q)
3          register queue_t *rdwr_q;
4  {
5     enableok(rdwr_q);
6     /* re-enable a queue that has been disabled */
7     (void) qenable(rdwr_q);
8  }

See Also

noenable(9F), qenable(9F)

Writing Device Drivers for Oracle Solaris 11.3

STREAMS Programming Guide