Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_getmtu(9F)

Name

net_getmtu - determine the MTU of a given network interface

Synopsis

#include <sys/neti.h>

int net_getmtu(const net_data_t net, const phy_if_t ifp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_lookup(9F).

ifp

value returned from a successful call to net_phylookup(9F) or net_phygetnext(9F).

Description

The net_getmtu() function receives information about the current MTU of a network interface. The value returned from this function call should not be cached as the MTU of a network interface since it is not guaranteed to be constant.

Return Values

The net_getmtu() function returns -1 if the network protocol does not support this feature and otherwise returns the current MTU of the network interface.

Context

The net_getmtu() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_phygetnext(9F), net_phylookup(9F), net_protocol_lookup(9F)