Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

geterror(9F)

Name

geterror - returnI/Oerror

Synopsis

#include <sys/types.h>
#include <sys/buf.h>
#include <sys/ddi.h>

int geterror(struct buf *bp);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

bp

Pointer to a buf(9S) structure.

Description

The geterror() function returns the error number from the error field of the buffer header structure.

Return Values

An error number indicating the error condition of the I/O request is returned. If the I/O request completes successfully, 0 is returned.

Context

The geterror() function can be called from user, interrupt, or kernel context.

See Also

buf(9S)

Writing Device Drivers for Oracle Solaris 11.3