Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

net_instance_protocol_unregister(9F)

Name

net_protocol_notify_register, net_instance_protocol_unregister - add/delete a function to be called for changes to a protocol

Synopsis

#include <sys/hook.h>
#include <sys/neti.h>

int net_protocol_notify_register(net_handle_t family, 
     hook_notify_fn_t *callback, void *arg);

int net_protocol_notify_unregister(net_handle_t family, 
     hook_notify_fn_t *callback);

typedef int (* hook_notify_fn_t)(hook_notify_cmd_t command,
     void *arg, const char *name1, const char *name2, const char 
     *name3);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

family

value returned from net_protocol_lookup().

callback

function to call when a change occurs.

arg

pointer to pass into the callback() function when a change occurs.

Description

The net_protocol_notify_register() function registers a function represented by the pointer callback to be called when there is a change to the protocol represented by family. The types of changes for which notifications are available for is currently limited to the addition and removal of protocols.

The net_protocol_notify_unregister() function removes the function specified by the pointer callback from the list of functions to call. This call may fail if the specified function cannot be found.

Multiple callback functions may be registered through this interface. The same set of parameters is passed to each callback function. The memory referenced through the pointers passed to the callback should be treated as pointing to read-only memory. Changing this data is strictly prohibited.

The function that is called must not block any other protocols.

The arguments passed through to the callback are as follows (the command is either HN_REGISTER or HN_UNREGISTER):

name1

is the name of the protocol

name2

is NULL.

name3

is the name of the protocol being added/removed

Return Values

If these functions succeed, 0 is returned. Otherwise, the following error is returned:

EEXIST

the given callback function is already registered.

Context

These functions may be called from user or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

attributes(5), net_protocol_lookup(9F)