Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

scsi_free_consistent_buf( 9F)

Name

scsi_free_consistent_buf - free a previously allocated SCSI DMA I/O buffer

Synopsis

#include <sys/scsi/scsi.h>

void scsi_free_consistent_buf(struct buf *bp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

bp

Pointer to the buf(9S) structure.

Description

The scsi_free_consistent_buf() function frees a buffer header and consistent data buffer that was previously allocated using scsi_alloc_consistent_buf(9F).

Context

The scsi_free_consistent_buf() function can be called from user, interrupt, or kernel context.

See Also

freerbuf(9F), scsi_alloc_consistent_buf(9F), buf(9S)

Writing Device Drivers for Oracle Solaris 11.3

WARNING

The scsi_free_consistent_buf() function will call freerbuf(9F) to free the buf(9S) that was allocated before or during the call to scsi_alloc_consistent_buf(9F).

If consistent memory is bound to a scsi_pkt(9S), the pkt should be destroyed before freeing the consistent memory.