Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

bp_mapout(9F)

Name

bp_mapout - deallocate virtual address space

Synopsis

#include <sys/types.h>
#include <sys/buf.h>

void bp_mapout(struct buf *bp);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

bp

Pointer to the buffer header structure.

Description

bp_mapout() deallocates system virtual address space allocated by a previous call to bp_mapin(9F).bp_mapout() should only be called on buffers which have been allocated and are owned by the device driver. It must not be called on buffers passed to the driver through the strategy(9E) entry point (for example a filesystem). Because bp_mapin(9F) does not keep a reference count, bp_mapout() will wipe out any kernel mapping that a layer above the device driver might rely on.

Context

bp_mapout() can be called from user context only.

See Also

strategy(9E), bp_mapin(9F), buf(9S)

Writing Device Drivers for Oracle Solaris 11.3