Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ddi_dma_free_handle(9F)

Name

ddi_dma_free_handle - free DMA handle

Synopsis

#include <sys/ddi.h> 
#include <sys/sunddi.h>

void ddi_dma_free_handle(ddi_dma_handle_t *handle);

Parameters

handle

A pointer to the DMA handle previously allocated by a call to ddi_dma_alloc_handle(9F).

Interface Level

Solaris DDI specific (Solaris DDI).

Description

ddi_dma_free_handle() destroys the DMA handle pointed to by handle. Any further references to the DMA handle will have undefined results. Note that ddi_dma_unbind_handle(9F) must be called prior to ddi_dma_free_handle() to free any resources the system may be caching on the handle.

Context

ddi_dma_free_handle() can be called from user, kernel, or interrupt context.

See Also

ddi_dma_alloc_handle(9F), ddi_dma_unbind_handle(9F)

Writing Device Drivers for Oracle Solaris 11.3