Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

csx_GetHandleOffset(9F)

Name

csx_GetHandleOffset - return current access handle offset

Synopsis

#include <sys/pccard.h> 

int32_t csx_GetHandleOffset(acc_handle_t handle, uint32_t *offset);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

handle

Access handle returned by csx_RequestIRQ(9F) or csx_RequestIO(9F).

offset

Pointer to a uint32_t in which the current access handle offset is returned.

Description

This function returns the current offset for the access handle, handle, in offset.

Return Values

CS_SUCCESS

Successful operation.

Context

This function may be called from user or kernel context.

See Also

csx_RequestIO(9F), csx_RequestIRQ(9F), csx_SetHandleOffset(9F)

PC Card 95 Standard, PCMCIA/JEIDA