Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

bioinit(9F)

Name

bioinit - initialize a buffer structure

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

void bioinit(struct buf *bp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

bp

Pointer to the buffer header structure.

Description

The bioinit() function initializes a buf(9S) structure. A buffer structure contains state information which has to be initialized if the memory for the buffer was allocated using kmem_alloc(9F). This is not necessary for a buffer allocated using getrbuf(9F) because getrbuf() will call bioinit() directly.

Context

The bioinit() function can be called from any context.

Examples

Example 1 Using bioinit()
		
struct buf *bp = kmem_alloc(biosize(), KM_SLEEP);
bioinit(bp); 
/* use buffer */

See Also

biofini(9F), bioreset(9F), biosize(9F), getrbuf(9F), kmem_alloc(9F), buf(9S)

Writing Device Drivers for Oracle Solaris 11.3