Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ldi_devmap(9F)

Name

ldi_devmap - Issue a devmap request to a device

Synopsis

#include <sys/sunldi.h>

int ldi_devmap(ldi_handle_t lh, devmap_cookie_t dhp, offset_t off, 
     size_t len, size_t *maplen, uint_t model);

Parameters

lh

Layered handle.

dhp

Opaque mapping handle used by the system to describe mapping.

off

User offset within the logical device memory at which mapping begins.

len

Mapping length (in bytes).

maplen

Pointer to length (in bytes) of validated mapping. (Less than or equal to len).

model

Data model type of current thread.

Description

The ldi_devmap() function passes an devmap request to the device entry point for the device specified by the layered handle. This operation is supported for character devices.

Return Values

The ldi_devmap() function returns 0 upon success. If a failure occurs before the request is passed to the device, possible return values are shown below. Otherwise any other error number may be returned by the device.

EINVAL

Invalid input parameters.

ENOTSUP

Operation is not supported for this device.

Context

This function may be called from user or kernel context.