Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

csx_MapMemPage(9F)

Name

csx_MapMemPage - map the memory area on a PC Card

Synopsis

#include <sys/pccard.h>

int32_t csx_MapMemPage(window_handle_t wh, map_mem_page_t *mp);

Interface Level

Solaris DDI Specific (Solaris DDI)

Parameters

wh

Window handle returned from csx_RequestWindow(9F).

mp

Pointer to a map_mem_page_t structure.

Description

This function maps the memory area on a PC Card into a page of a window allocated with the csx_RequestWindow(9F) function.

Structure Members

The structure members of map_mem_page_t are:


uint32_t     CardOffset;       /* card offset */
uint32_t     Page;             /* page number */

The fields are defined as follows:

CardOffset

The absolute offset in bytes from the beginning of the PC Card to map into system memory.

Page

Used internally by Card Services; clients must set this field to 0 before calling this function.

Return Values

CS_SUCCESS

Successful operation.

CS_BAD_HANDLE

Client handle is invalid.

CS_BAD_OFFSET

Offset is invalid.

CS_BAD_PAGE

Page is not zero.

CS_NO_CARD

No PC Card in socket.

CS_UNSUPPORTED_FUNCTION

No PCMCIA hardware installed.

Context

This function may be called from user or kernel context.

See Also

csx_ModifyWindow(9F), csx_ReleaseWindow(9F), csx_RequestWindow(9F)

PC Card 95 Standard, PCMCIA/JEIDA