Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

usb_pipe_get_max_bulk_streams (9F)

Name

usb_pipe_get_max_bulk_streams - Get maximum streams count on a USB bulk pipe

Synopsis

#include <sys/usb/usba.h>
int usb_pipe_get_max_bulk_streams(usb_pipe_handle_t *
pipe_handle, uint16_t *max_streams
);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

pipe_handle

Pointer to a USB bulk pipe handle.

max_streams

Returns the maximum streams count.

Description

Theusb_pipe_get_max_bulk_streams() function returns the maximum streams count that the host and client can support per bulk pipe. This information can be used by the USB client to decide how many streams can be allocated.

Return Values

USB_SUCCESS

Maximum streams count is returned in max_stream argument.

USB_INVALID_ARGS

pipe_handle is NULL and/or the max_stream argument isNULL.

USB_INVALID_PIPE

Pipe is closing or closed.

USB_NOT_SUPPORTED

The host does not support SuperSpeed streams.

Exception handlers of any queued requests which were flushed are called with a completion reason of USB_CR_FLUSHED.

Context

The allocation routines may always be called from kernel, user, or interrupt context.

Examples


uint16_t stream_max_cnt;

           if (usb_pipe_get_max_bulk_streams(pipe, &stream_cnt) !=
               USB_SUCCESS) {
           }

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI-based systems
Interface Stability
Committed
Availability
system/io/usb

See Also

attributes(5), usb_pipe_bulk_alloc_streams(9F), usb_pipe_bulk_free_streams(9F), usb_pipe_bulk_reset_stream(9F)