Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

mac_prop_info_set_range_uint32(9F)

Name

mac_prop_info_set_perm, mac_prop_info_set_default_uint8, mac_prop_info_set_default_str, mac_prop_info_set_default_link_flowctrl, mac_prop_info_set_range_uint32 - set property information

Synopsis

#include <sys/mac_provider.h>

void mac_prop_info_set_perm(mac_prop_info_handle_t ph,
    uint8_t perm);
void mac_prop_info_set_default_uint8(mac_prop_info_handle_t ph,
    uint8_t val);
void mac_prop_info_set_default_str(mac_prop_info_handle_t ph,
    const char *str);
void mac_prop_info_set_default_link_flowctrl(
    mac_prop_info_handle_t ph, link_flowctrl_t val);
void mac_prop_info_set_range_uint32(mac_prop_info_handle_t ph,
    uint32_t min, uint32_t max);

Description

The entry points described here are invoked from a device driver's mc_propinfo(9E) entry point to associate information such as default values, permissions, or allowed value ranges.

Each one of these functions takes as first argument the property information handle which is passed to mc_propinfo() as argument.

The mac_prop_info_set_perm() function specifies the property of the property. The permission is passed through the perm argument and can be set to one of the following values.

MAC_PROP_PERM_READ

The property is read-only.

MAC_PROP_PERM_WRITE

The property is write-only.

MAC_PROP_PERM_RW

The property can be read and written.

The driver is not required to call mac_prop_info_set_perm() for every property. If the driver does not call that function for a specific property, the framework will assume that the property has read and write permissions, corresponding to MAC_PROP_PERM_RW.

The mac_prop_info_set_default_uint8(), mac_prop_info_set_default_str(), and mac_prop_info_set_default_link_flowctrl() functions are used to associate a default value with a specific property.

The mac_prop_info_set_range_uint32() function is used by a driver to associate an allowed range of values for a specific property. The range is defined by the min and max arguments passed by the device driver. This function can be called successively to specify multiple non-overlapping ranges.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), mac(9E)