Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

pci_plist_get(9F)

Name

pci_plist_get - get the name-value pair list for the PF device

Synopsis

#include <sys/sunddi.h>

int pci_plist_get(pci_param_t param, pci_plist_t *plist_p);

Parameters

param

A handle obtained from pci_param_get(9F) or pci_param_get_ioctl(9F).

plist_p

A pointer to pci_plist_t where a non—null plist_p is returned on successful return

Description

The plist_p returned by pci_plist_get() is similar to nvlist_t and contains the name-value pairs for the PF (Physical Function) device. The pci_plist_t supports the following data types:

int8_t, uint8_t, int16_t, uint16_t, int32_t, uint32_t, int64_t, 
uint64_t, char *, pci_plist_t

Arrays of the above data types are supported except pci_plist_t.

Return Values

DDI_SUCCESS

On success.

Non-zero value

There is no name-value list for PF device.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Uncommitted

See Also

attributes(5), pci_param_free(9F), pci_param_get(9F), pci_plist_getvf(9F)