Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

scsi_unslave(9F)

Name

scsi_unprobe, scsi_unslave - free resources allocated during initial probing

Synopsis

#include <sys/scsi/scsi.h> 

void scsi_unslave(struct scsi_device *devp);
void scsi_unprobe(struct scsi_device *devp);

Interface Level

Solaris DDI specific (Solaris DDI). The scsi_unslave() interface is obsolete. Use scsi_unprobe() instead.

Parameters

devp

Pointer to a scsi_device(9S) structure.

Description

scsi_unprobe() and scsi_unslave() are used to free any resources that were allocated on the driver's behalf during scsi_slave(9F) and scsi_probe(9F) activity.

Context

scsi_unprobe() and scsi_unslave() must not be called from an interrupt context.

See Also

scsi_probe(9F), scsi_slave(9F), scsi_device(9S)

Writing Device Drivers for Oracle Solaris 11.3

Notes

The scsi_unslave() function is obsolete and will be discontinued in a future release. This function has been replaced by scsi_unprobe().