Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

ldi_remove_event_handler(9F)

Name

ldi_remove_event_handler - remove an NDI event service callback

Synopsis

#include <sys/ddi_obsolete.h>

int ldi_remove_event_handler(ldi_handle_t lh,
     ldi_callback_id_t id);

Interface Level

Obsolete

Parameters

ldi_handle_t lh

Layered handle representing the device for which the event notification is requested.

ldi_callback_id_t id

Unique system-wide registration ID returned by ldi_add_event_handler(9F) upon successful registration.

Description

This function is obsolete and is only maintained for compatibility. Use of this function is strongly discouraged. For equivalent functionality provided by new interfaces, see ldi_ev_register_callbacks(9F) and ldi_ev_remove_callbacks(9F).

The ldi_remove_event_handler() function removes the callback handler specified by the registration ID (ldi_callback_id_t). Upon successful removal, the callback handler is removed from the system and is not invoked at the event occurance.

Return Values

DDI_SUCCESS

Callback handler removed successfully.

DDI_FAILURE

Failed to remove callback handler.

Context

This function can be called from user and kernel contexts only.

See Also

ldi_ev_register_callbacks(9F), ldi_ev_remove_callbacks(9F), ldi_add_event_handler(9F), ldi_get_eventcookie(9F)

Writing Device Drivers for Oracle Solaris 11.3