Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

nochpoll(9F)

Name

nochpoll - error return function for non-pollable devices

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

int nochpoll(dev_t dev, short events, int anyyet, short *reventsp, 
      struct pollhead **pollhdrp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dev

Device number.

events

Event flags.

anyyet

Check current events only.

reventsp

Event flag pointer.

pollhdrp

Poll head pointer.

Description

The nochpoll() function is a routine that simply returns the value ENXIO. It is intended to be used in the cb_ops(9S) structure of a device driver for devices that do not support the poll(2) system call.

Return Values

The nochpoll() function returns ENXIO.

Context

The nochpoll() function can be called from user, interrupt, or kernel context.

See Also

poll(2), chpoll(9E), cb_ops(9S)

Writing Device Drivers for Oracle Solaris 11.3