Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2017
 
 

nodev(9F)

Name

nodev - error return function

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>

int nodev( );

Interface Level

Architecture independent level 1 (DDI/DKI).

Description

nodev() returns ENXIO. It is intended to be used in the cb_ops(9S) data structure of a device driver for device entry points which are not supported by the driver. That is, it is an error to attempt to call such an entry point.

Return Values

nodev() returns ENXIO.

Context

nodev() can be only called from user context.

See Also

nulldev(9F), cb_ops(9S)

Writing Device Drivers for Oracle Solaris 11.3